[RADIATOR] Mysql connector issue after Ubuntu version change

Gabe Carmichael Gabe at lksd.org
Tue Aug 23 21:24:31 UTC 2022

I have an instance where I updated Ubuntu to 20.04, from 18.04 and Im
getting a mysql driver missing error message. I have tried manually
installing it, updated CPAN and tried again, but thus far have been
unsuccessful. Anyone else try to go from 18.04 to 20.04 and get this error
message string?

00000000 Tue Aug 23 12:23:31 2022 503533: ERR: Could not connect to SQL
database with DBI->connect dbi:mysql:radiator:x.x.x.x, xxxxxx,
00000000 Tue Aug 23 12:23:31 2022 503681: ERR: Could not connect to any SQL
database. Request is ignored. Backing off for 600 seconds
00000000 Tue Aug 23 12:23:31 2022 504389: ERR: Radius::AuthSQL XXXX: SQL
connection to 'dbi:mysql:radiator:x.x.x.x:3306' failed:
install_driver(mysql) failed: Can't locate DBD/mysql.pm in @INC (you may
need to install the DBD::mysql module) (@INC contains:
/opt/radiator/radiator /etc/perl
/usr/local/lib/x86_64-linux-gnu/perl/5.26.1 /usr/local/share/perl/5.26.1
/usr/lib/x86_64-linux-gnu/perl5/5.26 /usr/share/perl5
/usr/lib/x86_64-linux-gnu/perl/5.26 /usr/share/perl/5.26
/usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base
/opt/radiator/radiator /opt/radiator/radiator-radius-utilxs) at (eval 96)
line 3.
00000000 Perhaps the DBD::mysql perl module hasn't been fully installed,
00000000 or perhaps the capitalisation of 'mysql' isn't right.
00000000 Available drivers: .
00000000  at /opt/radiator/radiator/Radius/SqlDb.pm line 360.

Any help would fantastic. Thanks


Gabe Carmichael
Device Management/Network/Voip Administrator
Lower Kuskokwim School District
LKSD Internal 4 digit dial - 4860
Skype: gabes72riv
gabe at lksd.org <gabe_carmichael at lksd.org>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.open.com.au/pipermail/radiator/attachments/20220823/bcf2677b/attachment.html>

More information about the radiator mailing list