[RADIATOR] Using unix crypto ?

Patrik Forsberg patrik.forsberg at globalconnect.se
Tue Apr 13 13:56:26 UTC 2021

I’m trying to use something like $2y$ crypto from a sql query but .. either I’ve failed in generation of the hash (using php password_hash) or something is missing to allow Radiator to verify against this hash .. so I’m wondering if there are any package that is needed ?
I’ve tried Crypt::Blowfish and Crypt::UnixCrypt but they made no difference whatsoever.. also tried installing the mcrypt package .. still no difference.. ☹

I’m running this under a Debian Linux 10 (buster).

I’ve tried to put radiator into trace mode(trace 9) but it doesn’t show anything wrong either (other then “bad password”).. and the passwordlog shows the correct password being received and the hash is what is expected from the sql.. so it is apparent that it is Radiator that decides that the password is wrong for some reason..

Best Regards,
Patrik Forsberg

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.open.com.au/pipermail/radiator/attachments/20210413/7c38cad3/attachment.html>

More information about the radiator mailing list